
    Chapter 3


    Querying spatial data in Munsys

Introduction
This chapter describes the various query options that are available in Munsys, with particular 
reference to:

 using the Munsys Query palette

 the different objects that can be queried from the database

 specifying and creating a Geographic Search Criteria (GSC)

 adding a spatial view

 querying cadastral data from the database, using both the Query palette and the Query 
menu

 browsing information

 showing information about spatial objects using the Munsys Info palette

 setting different coordinate systems

 creating a Munsys report
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About queries
Queries can be defined as statements or logical expressions that are used to retrieve spatial data 
or records from a database. In Munsys, the data that you work with is queried from spatial tables 
in the database and displayed in the drawing area.

All users accessing the database have query privileges, although they do not necessarily have the 
privileges to update the spatial tables in the database.

Munsys has simplified the query process by providing a list of pre-defined (default) system 
queries for each application on the Query menu and the Query Palette. At least one query for 
every spatial object exists in the MUNSYS_QUERY table in the database.

Users who have the Munsys Query and/or Munsys Edit roles assigned can query data from the 
database using the system queries, and also save their own user-defined queries for re-use. Users 
who have the MUNSYS_ADMIN and MUNSYS_POWER roles assigned can modify the 
system queries for use by all users.

User queries are stored in the MUNSYS_QUERY table in the database. Queried data is 
displayed on AutoCAD layers. When data is queried from the database, Munsys automatically 
generates the required layers, for example sewer nodes are queried onto the SEWNODE layer, 
and residential water pipes are queried onto the WATRESPIPE layer. You don’t have to set up 
any layers before you query data from the database. 

Figure 1 Each object type is displayed on its own layer

Normally, a very large amount of data is stored in the database. In Munsys, data can be 
requested for a specific geographical area, which is formulated by specifying a Geographic 
Search Criteria (GSC). With the GSC and various query functions, Munsys users can retrieve 
relevant data easily in small, “digestible” chunks to ensure a fast processing speed and small, 
workable areas. Before you can retrieve data for a specific area, you first have to specify the GSC. 
Read more about GSC in the following section.

Sewer nodes are queried onto 
the SEWNODE layer.
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Introducing query categories
Query categories are set in the Munsys Management Console and are used to group queries and 
data into an organization’s recognized data categories. The following category types are 
available:

 Uncategorized – by default, any new query (not a user query) is seen as being uncategorized 
until it has been allocated to a category. Queries can be moved to or from the uncategorized 
group, but the category itself is a special case whereby the name may not be changed – only 
the content.

 User – whenever a user creates a new query, it is automatically seen as a personal query, 
hence called a User query. Other users cannot see any other user’s queries until they are 
shared in the pool of Uncategorized or Categorized queries.

 Custom Categories – each category is provided with a unique name. When a new category 
is created, it is automatically granted the MUNSYS_ALL_QUERY role. A category may be 
granted multiple roles.

Munsys provides default custom categories as part of a new schema. The power user has the 
ability to customize these and/or add personal categories. The following categories are created 
in a new schema, synonymous with the Munsys applications and the default roles are granted 
to these categories:

 Cadastral – MUNSYS_CMS_QUERY
 Drainage – MUNSYS_DMS_QUERY
 Electricity – MUNSYS_EMS_QUERY
 Roads – MUNSYS_RMS_QUERY
 Sewer – MUNSYS_SMS_QUERY
 Water – MUNSYS_WMS_QUERY
 Spatial Data Manager - MUNSYS_SDM_QUERY
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Introducing the Munsys Query Palette
The Munsys Query Palette provides a new, alternative interface in which queries, query 
categories and GSCs have been consolidated in order to provide an easy, user-friendly way to 
manipulate these items.

Figure 2 The Munsys Query Palette

The Query Palette is activated in the AutoCAD environment with the MUNQRYPALETTE 
command, or checking the Query Palette item on the Query menu. 

The palette is dockable and remains open until the user closes it. The position and status 
settings of the Query Palette are stored in the registry so that when a new session is started, the 
system restores the palette to the state it was in when the previous session ended.

The Query Palette consists of a toolbar, GSC pane and a Query pane.

Query Palette toolbar

GSC Pane

Query Pane
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The Query Palette toolbar provides access to functions that are common and related to the 
query process.

Figure 3 The Query Palette toolbar

The following buttons are available on the toolbar:

 GSC Settings – used to set properties for the active GSC

 Create New GSC – activates the Unnamed GSC and enables users to create a new GSC.

 Show Active GSC – shows the geometry of the active GSC, relative to its current zoom state

 Zoom GSC Extents – zooms to the extents of the active GSC

 Zoom DB Extents – zooms to the extents of the database

 Query Preferences – provides options to specify settings that will determine the format and 
conditions when spatial data is retrieved from the database

 Run Checked Queries – executes queries that have been checked in the Query pane of the 
Query Palette

 Run Query – displays a list of all the queries that are available to the current user. Queries 
can be selected and then run from this list.

 Browse Info – opens the Browse Info modeless window.
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The GSC pane contains a list of System and user-created GSCs, of which certain properties can 
be manipulated by means of a context-sensitive (right-click) menu. 

Figure 4 Query Palette GSC Pane: Context-sensitive (right-click) menu

You can do the following using the context-sensitive menu:

 Set a selected GSC as the current GSC

 Delete or rename a GSC

 Zoom to and show a selected GSC

 Create CAD objects from a GSC

 Modify certain properties of a GSC

 Add one or more objects to a GSC

 Set the query mask for a GSC
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The Query Palette: Query pane

The Query Palette Query pane contains a tree with a list of queries that have been grouped into 
user queries, categorized queries and uncategorized queries. 

Query categories and queries are manipulated from a context-sensitive (right-click) menu that 
is displayed when a query category or query is selected on the Query Palette.

Figure 5 Query palette: Query context-sensitive menus

You can do the following using the Query and Query Category context-sensitive menus:

 Run all the queries in a query category

 Run checked queries in a query category

 Create a new user query with the Query Details dialog box

 Discard changes that have been made to queries using the Reset and Reset All options. 
Queries that have changed, are marked with a *.

 Run one or more selected queries in a query category.

 Copy, delete or rename a query

 Save a modified query

 Save a query under a different name and in another query category

 Set a filter condition for a query

 Change the properties of a query
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Specifying Geographic Search Criteria (GSC)
GSCs can be created and manipulated from the Query Palette, the Query menu or the 
command line. 

To simplify the retrieval of data from the database, Geographic Search Criteria (GSC) have to 
be defined. A GSC locates spatial objects from the database by their geographical location, 
making use of a polygon, window, fence, radius or object definition. The GSC settings apply 
restrictions on the geographical extent of spatial data extracted from the database.

Multiple GSCs can be created. Where in the past only one set of parameters could be saved to 
be used as a spatial filter, the GSC functionality has now been extended to save these parameters 
under various names. A single GSC is selected as the active GSC, which is used as the spatial 
criteria when spatial objects are retrieved from the database.

One GSC, the Unnamed GSC, is reserved as the default GSC. Whenever a user creates a new 
GSC, the parameters are saved with the Unnamed GSC until it is renamed. When this happens, 
the parameters are saved under the new name, and the Unnamed GSC is left with the last 
parameters used. A user can have as many GSCs saved as is required, but only one GSC can be 
active at a given time. When changing properties of a GSC, this will be applied to the active 
GSC. Whenever changes are made, they are saved directly into the database.

Munsys offers two types of GSCs:

 System GSCs are GSC, created by Systems Administrators, and then saved as System GSC. 
Saving a GSC as a System GSC effectively shares that GSC amongst all users. 

 User GSC are associated with specific users; these GSCs are not shared. The list of GSCs 
presented to the user is filtered by user name. New User GSCs are saved with the currently 
logged on user name.

All GSCs are associated with a user; GSCs may not be shared. The list of GSCs presented to 
the user is filtered by user name. New GSCs are saved with the currently logged on user name.

When a GSC is created, a GSC mask also needs to be specified. The GSC mask determines how 
the GSC is applied as a spatial filter when retrieving data from the database. The following mask 
settings are available:

 Approximate – approximate conditions will retrieve data in the vicinity of the GSC, which 
is a very fast process. The GSC can be defined by means of a polygon, window, circle or 
fence. A GSC with the mask set to approximate is displayed as a dashed line.

 Crossing – retrieves spatial objects within and crossing a GSC. The GSC can be defined by 
means of a polygon, window, circle or fence. A GSC with the mask set to crossing is 
displayed as a dashed line. A point with a buffer can also have a mask of crossing.

 Within – retrieves spatial objects completely within a specified GSC. The GSC can be 
defined by means of a polygon, window or circle. A GSC with the mask set to within is 
displayed as a solid line. A fence and point GSC with a buffer can have a mask of within.
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You can also place a buffer around a GSC. A buffer adds a zone of a specified width around 
the selected GSC, as seen in the following examples:

Figure 6 Buffered GSC

Polygon with islandFencePoint
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Specifying GSC settings

Spatial objects are retrieved from the database using a GSC (Geographic Search Criteria). GSC 
settings apply restrictions on the geographic extent of spatial data retrieved from the database. 
The GSC Settings dialog box is used to specify parameters when a new GSC is created, or to 
change the properties of the current GSC. The GSC Settings dialog box is divided in two tabs: 
GSC Definition and Options. The GSC Definition tab is used to specify the GSC mode 
(whether the GSC is determined by an object or defined manually). The GSC Definition tab 
is only available when the Unnamed GSC is active – the definition of previously saved GSCs 
cannot be changed.

To specify GSC settings

1 Do one of the following:

 Choose Query > GSC > GSC Settings.

 Click the GSC Settings button on the Munsys main toolbar or the Query Palette toolbar.
The GSC Settings dialog box is displayed. 

Figure 7 The GSC Settings dialog box 

2 From the GSC Mode list, select one of the following:

 User-defined – a user-defined geographic search boundary.

 From Object – a selected spatial object is used as the GSC boundary. The command line 
will prompt you to select the spatial object that you want to use as a GSC when creating a 
new GSC. The selected object should exist in the database in order to be used as a GSC.
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3 Select the appropriate GSC type from the GSC Types list if you are creating a user-defined GSC. 
The GSC type could be one of the following:

 Window – a rectangle defined by two points.

 Fence – defined as a polyline consisting of a string of points. You can use the Within mask 
if a buffer is specified. 

 Polygon – a polygon boundary defined by more than two points. The polygon can be any 
shape, but cannot cross or touch itself. Munsys draws the last segment of the polygon so 
that it is closed at all times.

 Circle – a circle defined by a centre point and a radius.

 Point – defined as a single point. You can only use the Within mask option when a buffer 
has been specified around the point.

4 When choosing By Object, the following table explains the type of GSC as a result of selecting an 
AutoCAD object:

5 Next, click the Options tab.

Figure 8 GSC Settings: Options 

AutoCAD object GSC Comment

LWPOLYLINE
LINE
ARC

FENCE LWPOLYLINES with an Open status will result in a fence type 
GSC

MPOLYGON
LWPOLYLINE
CIRCLE

POLYGON LWPOLYLINES with a Closed status will result in a polygon 
type GSC

POINT
BLOCK
TEXT

POINT
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6 From the Object Query Mask group, select the mask type. This will determine the number of spatial 
objects to retrieve from the database.

7 To specify a buffer, do the following:

 From the Buffer Options group, set the Create a Buffered GSC check box.

 Enter the buffer distance in the text box or click the Buffer Options button to specify the buffer 
distance manually in the drawing. This is done by indicating two points in the drawing. The 
straight-line distance between the two points that you specified are populated to the text box.

8 Click OK to save the GSC settings.
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Creating a GSC
A new GSC is created according to the settings that you specified on the GSC Settings dialog 
box. You can create a new GSC from the Query Palette toolbar, the Munsys Main, from the 
Query menu, or from the Munsys main toolbar.

To create a GSC from an object

1 Make certain that you have set the GSC Mode to By Object in the GSC Settings dialog box, and 
that you have specified the buffer options (if required) and the appropriate mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Select the object that you want to use as a GSC, as prompted by the command line. You can use any 
spatial object (both Munsys and CAD objects) in the current drawing to create the GSC from. 

The following figure shows a GSC that has been created using a community (township, 
municipality or suburb) boundary as GSC object, with the mask set to Within. Parcels have 
been queried from the database according to the GSC.

Figure 9 Example of a GSC created by Object

The community boundary has been 
selected as the object to use as a GSC, 
with the mask set to Within. Parcels 
have been queried according to the 
current GSC.
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To create a window GSC

1 Make certain that you have set the GSC type to Window on the GSC Settings dialog box, and that 
you have specified the buffer options (if required) and the appropriate object query mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the first corner of the window.

4 Using the mouse, resize the window, and then click to indicate the second corner.

The following figure shows a window GSC, which has been created with a buffer of 200, and with 
the mask set to Within. The parcels have been queried from the database according to the GSC.

Figure 10 Example of a window GSC

To create a fence GSC

1 Make certain that you have set the GSC type to Fence on the GSC Settings dialog box, and that you 
have specified the buffer options (if required) and the appropriate object query mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the first fence point.

A buffer has been specified 
around the GSC.

A window GSC. 
The GSC outline is 
displayed as a solid 
line, because the 
mask has been set to 
Within.
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4 Indicate the next point(s), and then press ENTER to end the fence definition.

The following figure shows a fence GSC with the mask set to Approximate, and with no buffer 
specified. The parcels have been queried from the database according to the GSC.

Figure 11 Example of a fence GSC

To create a polygon GSC

1 Make certain that you have set the GSC type to Polygon in the GSC Settings dialog box, and that 
you have specified the buffer options (if required) and the appropriate mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

A fence GSC. The GSC outline 
is displayed as a dashed line, 
because the mask has been set 
to Approximate.
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3 Indicate the first polygon point.

4 Indicate the next polygon points, and then press ENTER. 

Munsys automatically closes the polygon by snapping to the first indicated point.

The following figure shows a polygon GSC with the mask set to Within, and with no buffer 
specified. The parcels have been queried from the database according to the GSC.

Figure 12 Example of a polygon GSC

A polygon GSC. The GSC outline is 
displayed as a solid line, because the mask 
has been set to Within.
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To create a circle GSC

1 Make certain that you have set the GSC type to Circle in the GSC Settings dialog box, and that you 
have specified the buffer options (if required) and the appropriate mask.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the center point of the circle.

4 Using the mouse, resize the circle and then click to apply, or type the radius on the command line.

The following figure shows a circle GSC with the mask set to Crossing, and with no buffer specified. 
The parcels have been queried from the database according to the GSC.

Figure 13 Example of a circle GSC

A circle GSC. The GSC outline 
is displayed as a dashed line, 
because the mask has been set to 
Crossing.
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To create a point GSC

1 Make certain that you have set the GSC type to Point in the GSC Settings dialog box, and you have 
specified the buffer options (if required) and the appropriate mask.

Tip If you do not specify a buffer around the point GSC, the Within mask will be unavailable.

2 Do one of the following:

 Choose Query > GSC > Create New GSC.

 Click the Create New GSC button on the Query Palette toolbar.

 Click the Create New GSC button on the Munsys Main toolbar.

3 Indicate the point that you want to use as a GSC.

The following figure shows a point GSC, with the mask set to Within, and with a buffer of 150 
specified. The parcels have been queried from the database according to the GSC.

Figure 14 Example of a point GSC

A point GSC, with a buffer of 300. 
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To show the active GSC

 Choose Query > GSC > Show Active GSC.

 Click the Show Active GSC button on the Query Palette or Munsys Main toolbar.

The current active GSC is displayed as a dotted outline when the mask has been set to 
Approximate or Crossing, or as a solid outline when the mask has been set to Within. If a 
buffer has been specified, it is showed as a colored outline on the outside of the GSC 
boundary.

Figure 15 Showing the active GSC

To zoom to the GSC extents

 Choose Query > GSC > Zoom to GSC Extents.

 Click the Zoom to GSC Extents button on the Query Palette or Munsys Main toolbar.

This command will zoom to the full extents of the current GSC.
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Converting a GSC to an AutoCAD object
With this function, the current GSC can be converted to an AutoCAD object as a Polyline or 
Point object type, for example if you want to display the GSC in a map. A Munsys point GSC 
will be converted to an AutoCAD point, while all the other GSC types will be converted to 
Polyline objects. If the GSC to be converted was constructed from a Munsys complex object, 
multiple AutoCAD objects will be created for each component of the GSC. For example, if the 
GSC consists of a polygon with an island, the result will be two polyline objects.The AutoCAD 
object is created on the GSC layer. If a buffered GSC is converted, the buffer is stored on the 
GSC_BUFFER layer.

To convert a GSC to an AutoCAD object

1 Do one of the following:

 Choose Query > GSC > Create Object From GSC.

 Choose Query Palette, right-click on the GSC that you want to convert, and then select the 
Create CAD Objects from GSC option on the context-sensitive menu that is displayed.

 On the command line, enter MUNGSCTOCAD.
The current GSC is converted to the appropriate AutoCAD object type and placed on the GSC 
layer. If a buffer was specified, the buffer is placed on the GSC_BUFFER layer.
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GSC functions on the Query Palette
Certain GSC functions can only be performed from the Munsys Query Palette. This section 
discussed these options.

Setting a GSC as current

To set a GSC as the current GSC, do the following:

1 On the Query Palette GSC Pane, select the GSC that you want to set as the current GSC, and then 
select the Set as Current GSC option from the context-sensitive menu.

2 The GSC is set as the current GSC and marked as such, as seen below:

Figure 16 Setting a GSC as Current

Deleting a GSC

With this function, you can delete a GSC. The Unnamed GSC or a GSC that has been set to 
Current cannot be deleted.

To delete a GSC, do the following:

1 On the Query Palette GSC Pane, select the GSC that you want to delete, and then select the Delete 
option from the context-sensitive menu.

The following message is displayed:

Figure 17 Deleting a GSC

2 Click Yes to delete the GSC.

The GSC entry is deleted from the database.

A GSC set to Current. 
Queries are executed according to 
the current GSC.
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Renaming a GSC

To rename a GSC, do the following:

1 On the Query Palette GSC Pane, select the GSC that you want to rename, and then select the 
Rename option from the context-sensitive menu.

Rename the GSC as required.

Figure 18 Renaming a GSC

Save a GSC as System GSC

Power-users and Systems administrators also have the functionality to save an existing GSC as 
a System GSC. A System GSC is any GSC that is shared between all users but can only be edited 
by admin users. To Create a System GSC follow these steps:

 Create any GSC using the functionality explained above.

 On the Query Palette GSC Pane, select the GSC that you just created (or any GSC you 
want to use as System GSC), and then select the select the Save as System GSC option from 
the context-sensitive menu. You will notice that the System GSC is now listed with a 
different icon.

Figure 19 System GSC
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Changing the properties of a GSC
Certain properties of the current GSC (unnamed or saved) can be changed using the GSC 
Settings dialog box. Changes to previously saved GSCs can be made to the query mask and the 
buffer options. The GSC Mode of saved GSCs cannot be changed, and the GSC Definition tab 
of the GSC Settings dialog box will remain unavailable. Changes made to the GSC properties 
are saved directly to the database. 

1 On the Query Palette GSC Pane, select the GSC that you want to modify, and then select the 
Properties... option from the context-sensitive menu.

The GSC Settings dialog box is displayed, showing the Options tab.The name of the GSC that is 
being changed is displayed on the title bar.

Figure 20 The GSC Settings dialog box: Options tab

2 Change Object Query Mask and/or the Buffer Options as required, and then click OK.

Adding objects to a GSC

With this function, you can add objects to the active GSC when the GSC Definition Mode has 
been set to From Object. When objects have been added, they cannot be removed, and a new 
GSC has to be created. This function can also be executed from the command line using the 
MUNGSCADDOBJ command. This function can only be used when Mun_DB_SETTINGS 
table in the Oracle database has the following row set (for Oracle EE license): Insert into 
MUNSYS_DB_SETTINGS the values ('S', 'MUNSYS_EE', 'T', 'Munsys Edition').

1 To add objects to a GSC, do one of the following:

 On the Query Palette GSC pane, select the current GSC, and then select the Add Object(s) 
to GSC from the context-sensitive (right-click) menu.

 On the command line, enter MUNGSCADDOBJ.

2 Select the object that you want to add to the GSC (the current GSC is highlighted), and then press 
ENTER.
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3 Repeat Step 2 until you have selected all the objects that you want to add to the GSC.

The object(s) that you have selected are added to the GSC.
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Querying data from the database using the Query Palette
This section describes how to query data from the database using the Query Palette. You can 
do the following:

 Specify query preferences

 Create new queries and specify and change properties for queries

 Run queries

Specifying query preferences

The Query Preferences function is used to specify settings that will determine the format and 
conditions when spatial data is retrieved from the database. These options are stored in the 
registry and do not have to be set every time a new Munsys session is started. The following 
options are available:

 Use GSC – if this option is selected, the currently active GSC is applied as a spatial filter 
when the required objects are retrieved from the database.

 Create CAD Objects – if this option is selected, the objects are retrieved from the database 
as AutoCAD drawing objects instead of Munsys objects.

 Attach Object Data – if this option is selected, attributes will be attached to the objects that 
are retrieved from the database. The objects may be Munsys or AutoCAD related. The 
attributes are always obtained from the primary spatial table. If the query is associated with 
a data group that relates the object(s) to an attribute table, the attribute will also include the 
columns from the retrieves all parcels or communities according to their status. (This 
option is only available when Munsys is run on AutoCAD Map.)

To specify query preferences, do the following:

1 Click the Query Preferences button on the Query Palette toolbar. (This function is also available 
on the Munsys Applications Query menu and the Munsys Main toolbar).

The Query Preferences dialog box is displayed.

Figure 21 The Query Preferences dialog box
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Select or clear any of the following check boxes:

 Use GSC – select this option if you want to apply the currently active GSC as a spatial filter 
when the objects are queried from the database.

 Create CAD objects – select this option to query the objects from the database as AutoCAD 
drawing objects instead of Munsys objects.

 Attach Object Data – this option is only available when Munsys is run on AutoCAD Map. 
Select this option if you want attributes to be attached to the objects that are queried from 
the database. The objects may be Munsys or AutoCAD related. The attributes are always 
obtained from the primary spatial table. If the query is associated with a data group that 
relates the object(s) to an attribute table, the attribute will also include the columns from 
the attribute table.

2 Click OK to apply the settings.

The settings are saved in the registry under the [HKEY_CURRENT_USER\Software\Open 
Spatial\Munsys[version]\Applications\Options key]

Creating a user-defined query

User-defined queries are created with the Query Details dialog box. Specific properties for each 
query are set using the Query Properties dialog box.

To create a user-defined query, do the following:

In the Query Palette Query pane, Select the New Query... option from the context-sensitive 
menu, as seen below:

Figure 22 Create New Query

The Query Details dialog box is displayed.
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Figure 23 The Query Details dialog box

3 Enter the following information:

 Query Name – enter a unique name for the new query. If a similar query already exists, you 
will be notified with an error message.

 Based on Spatial Object – select a spatial object to base the query on.

 Query Priority Order – enter a value between 0 and 100. A low number means that the 
query will be executed before queries with higher numbers. This means that queries with a 
higher number will be executed towards the end of the query process, causing the objects 
with a higher priority to be placed on top of the objects queried from queries with a low 
query priority.

4 Click OK to save the new query.

The query is saved and displayed in the list of available queries.

Specifying or changing query properties

The Query Properties dialog box is used to modify existing queries and to specify settings for 
user-defined queries. Using this dialog box, you can specify the formatting properties and 
informational data that is used as input to the query process. Because queries result in different 
object types, regardless of whether they are Munsys objects or AutoCAD objects, each object 
type has its own unique set of properties that may be changed to influence the outcome of the 
data that is retrieved from the database. These properties primarily include the display 
formatting options, but also allow the user to change the reference to data.

Because each object type has its own unique set of properties that may be modified to influence 
the outcome of the data, the contents of the Query Properties dialog box will vary according to 
the object type of the query that has been selected. These properties primarily include the 
display formatting options, but also allow the user to change the reference to data. Properties 
are changed using the context-sensitive (right-click) menu that is displayed when a property is 
selected.
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The contents of the Query Properties dialog box is displayed two panes:

 Property Category – the left pane contains the names of the various property categories. 
Clicking a category affects the contents that are displayed in the right pane, the Category 
Pane. 

 Property Items – the right pane, the Property pane, contains a list of properties that is 
determined by the property category being selected.

The Query Properties dialog box is displayed:

Figure 24 The Query Properties dialog box

All queries have the following properties:

 Base Properties: the basic properties of the query, for example the layer name, the object 
type, the query category of the query, the query name, the query priority order, etc.

Note The Base Properties option Filter objects by GSC is used to specify whether you want the current GSC 
applied to the query. When this option is set to Yes (the default), the objects will be retrieved from the 
database according to the GSC settings of the Current GSC. If you change the setting to No, all the data 
from the specific spatial table will be retrieved from the database.

Figure 25 Query Properties: Filter by GSC
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 Filter Condition: allows the user to specify criteria that will be used to filter the data during 
the query process 

 Table Information: the Linked Table property may be changed using the context-sensitive 
(right-click) menu, which displays the Linked Table Information dialog box. All other 
tables are inherited when the query was created.

Figure 26 Table Information: Properties

Figure 27 The Linked Table Information dialog box

Depending on the object type, various other query properties are displayed for a selected query, 
for example a MunPoint object will display Symbol Properties and Tag Properties, while a 
MunPoly object will display Polygon Properties and Tag Properties. All properties are changed 
using the context-sensitive (right-click) menu that is displayed when a property is selected, as 
seen in the following example:
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Figure 28 Query Properties: Context-sensitive menu

Specifying a filter condition for a query

A Filter Condition allows users to specify criteria that will be used to filter the data during the 
query process.

A filter is optional and when present, consists of one or more SQL statements that will are sent 
to the database. The conditions are specified using the SQL syntax. The expression syntax 
should be correct, otherwise the query will fail.

The conditions that apply to the query are listed in the Property Pane, as seen below:

Figure 29 Filter condition: Parcels query

Conditions are added or removed using the context-sensitive (right-click) menu. The sequence 
in which the conditions appear (from top to bottom) is the sequence in which they will be 
executed.
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Figure 30 Filter condition: Context-sensitive menu

The first condition must not have a Joiner (AND/OR), but from the second condition on this 
is required. When the query is executed, the conditions are concatenated to form a single 
combined expression. When column names are used, they are prefixed with the table name as 
in: SP_WATPIPE.PIPE_MATRL

This rule applies even if there is only one table associated with the query, because the query may 
eventually be joined with the MUNSYS_GSC table in order to filter on spatial characteristics 
of the data.

The Filter Condition context-sensitive (right-click) menu is used to edit existing conditions, or 
add new conditions.

 Remove Condition – deletes the condition

 Edit Condition – edits the condition as a SQL expression

 Add Condition – allows the user to add a new condition to the end of the list of conditions. 

 Clear All Filter Conditions – removes all conditions

 Check Syntax – verifies the syntax of the combined set of expressions

Adding a condition to a query
To add a condition, do the following:

1 Right-click on the query to which you want to add the condition, and then select the Filter 
Condition... option on the context-sensitive menu.

The Query Properties dialog box is displayed.

2 In the content pane, right-click on Condition List, and then select 
Add Condition... from the context-sensitive menu

The Add Condition dialog box is displayed.
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Figure 31 The Add Condition dialog box

3 Specify the following:

 A Joiner – the joiner is used to join a previous condition to a new condition, and is 
unavailable when the first condition is set for a query. Available values in the down list are 
AND and OR. When the joiner is selected, the other fields become available.

 Column – this list is populated with a list of all the columns from all the tables that may be 
referenced by the query. All the columns are prefixed by the table name.

 Operator – the Operator is used to specify how the value from the column will be compared 
to the value specified in the Value text box. This list is populated with the following values:

 = Equal To

 > Greater Than

 >= Greater Than or Equal To

 < Less Than

 <= Less Than or Equal To

 <> Not Equal To

 Like SQL “LIKE” command (value to be prefixed or suffixed with %)

 In SQL “IN” command (values to be comma delimited as in: ‘A’,’B’,’C’)

 Is Null SQL “IS NULL” command (no value allowed)

 Is Not Null SQL “IS NOT NULL” command (no value allowed)

 Value – select one or more values that will be used as comparison value against all values 
from the specified column. Use the Value button to select the value(s) from the database, 
as seen in the following example:
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Figure 32 Add Condition: Unique values

 SQL Equivalent – this field is populated when the other field have been filled in.

4 Click OK to add the condition to the list of conditions.

The condition is added to the Condition list, and the modified query is marked with a * in the query 
list.

Figure 33 Condition added to the list

5 To save the changes to the query, right-click on the query, and then select the Save or Save As... 
option on the context-sensitive menu.
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Figure 34 Saving changes to a query
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Executing queries from the Query Palette

Queries can be executed from the Query Palette by:

 Selecting the Run All Queries in Category option from the context-sensitive menu that is 
displayed when a query category is selected

 Checking the queries that you want to run (you can select queries from various query 
categories), and then selecting the Run Checked Queries option on the context-sensitive 
menu

 By clicking the Run Query button on the Query Palette toolbar, and then running selected 
queries from the Query List dialog box (this option is also available on the Munsys 
Applications Query menu and Main toolbar)

Figure 35 Query execution options
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Running checked queries from the query list
On the Query Palette Query pane, you can run multiple queries by selecting the check boxes 
adjacent to the relevant queries. You can also use the MUNQRYMULTIPLE command for this 
purpose. Before the queries are executed, they are sorted according to their query priority query 
priority order.

The queries that have been selected are run in order of their query priority; queries with a 
priority of 0 are run first, followed by queries with a higher number. As the queries are run, 
feedback about the number of objects retrieved is provided on the command line.

1 To run multiple checked queries, do one of the following:

 On the Query pane, select the check box(es) adjacent to the query or queries that you want 
to run, and then click the Run Checked Queries button on the Query Palette toolbar or the 
context-sensitive menu.

 On the command line, enter MUNQRYMULTTIPLE, and then follow the prompts.

The objects are retrieved from the database in their query priority order, and the command line 
shows the number of objects that are retrieved from the database for each query.

Running multiple queries using the Query List dialog box
A selection of one or more predefined queries can be run using the Query List dialog box, which 
can be called from the Query Palette toolbar, the Query menu, or the command line. The list 
of queries on the dialog box shows the name of the query, the category it belongs to and its 
priority, in descending order. 

Tip The list can be re-sorted by clicking on the appropriate header. 

The list of queries that is displayed on the dialog box is dependent on user privileges. This is 
firstly restricted by the roles assigned to the user, since the query categories restrict access to the 
queries in the category through roles. Secondly, access to queries is also restricted by the 
privileges assigned to the user with regard to the tables referenced in the queries. 

The queries that have been selected are run in order of their query priority; queries with a 
priority of 0 are run first, followed by queries with a higher number. As the queries are run, 
feedback about the number of objects retrieved is provided on the command line.

Tip Use the Query Preferences button on the Query List dialog box to specify query preferences in the 
Query Preferences dialog box before the queries are executed.

1 To run multiple queries using the Query List dialog box, do one of the following:

 Click the Run Query button on the Query Palette toolbar.

 Choose Query > Run Query.

 Click the Run Query button on the Munsys Main toolbar.

 On the command line, enter MUNQRYRUN.
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The Query List dialog box is displayed.

Figure 36 The Query List dialog box

2 Select the queries that you want to run from the list of available queries. Use the Query Preferences 
button to specify query preferences before the list of queries is run, as seen in the example above.

3 Click the Run button to run the selected queries.

The queries are run according to their query preference, and the command line displays the 
number of objects that were retrieved from the database for each query.

Tip You can use the context-sensitive (right-click) menu on the Query List dialog box to check or uncheck 
all the queries in a specific category.

Figure 37 Query List dialog box: context-sensitive menu
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Adding a spatial view
The Add Spatial View function is used to map an existing external (non-Munsys) spatial table 
so that Munsys may recognize it as a “Munsys table”, and that the data in the table can be 
queried using Munsys Applications.

Important  To be able to create a view on a table that resides in another schema, you need the SELECT 
privilege on the view. In order to grant the SELECT privilege on the newly created view to the Munsys 
roles you need to have the SELECT... WITH GRANT OPTION privilege on the original table granted to 
you (not through a role). For more details on granting the correct privileges, consult the appropriate Oracle 
documentation.

To create a spatial view for an external table, the following is required:

 The name of the schema where the existing spatial table resides.

 A spatial table that contains one MDSYS.SDO_GEOMETRY column. The Add Spatial 
View dialog box displays a list of tables that qualify. The qualification filter ensures that the 
table has sufficient user privileges to create a view on the table and to grant the SELECT 
privilege to Munsys roles, contain an SDO_GEOMETRY column and have a unique 
NUMBER ID column as primary index.

 A geometry type (point, symbol, label, line or polygon) that will be used throughout the 
table – this means that the complete set of records encountered in the table must all share 
the same geometry type.

 A unique name and description string used to identify the spatial view within the Munsys 
schema.

When executed, the function creates a view in the Munsys Schema, adds entries to the system 
tables and creates a system query that may be used as the default query. This system query will 
not query any tag information, but can be edited for this purpose, using the query palette. A 
spatial view that is no longer required can be removed using the Remove Spatial View function.

Note If the user doesn't have the required privileges to create a view on the selected table, an error message is 
displayed. This error normally only displays if the user doesn't have the SELECT privileges granted to 
the schema owner directly (not through a role). This error also indicates that the WITH GRANT 
OPTION is required. (The WITH GRANT OPTION is an additional clause that gives the necessary 
privileges to grant privileges on the newly created view to the default Munsys roles.) The following SQL 
statement is an example of the statement that should be used by the database administrator to grant the 
required privilege to the Munsys schema owner: grant select on schema name.sp_tablename to schema 
owner with grant option; 
When this error message is displayed, you will have to cancel the creation of the view, and then reconnect 
to the database after the correct privileges were granted by the database administrator as indicated above.
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To add a spatial view

1 Connect to the Oracle database as the owner of a Munsys schema. This is done by selecting the same 
user name and schema name when logging on to the database using the File > Connect to Database 
menu option, or the Connect to Database toolbar button.

2 On the command line, enter MUNADDSPVIEW.

The Add Spatial View dialog box is displayed.

Figure 38 The Add Spatial View dialog box

3 In the Original Table group, do the following:

 From the Schema Name list, select the schema where the spatial table resides. (Only schema 
names that contain tables with at least one column with a data type of SDO_GEOMETRY 
are displayed in this list.)

Figure 39 Selecting the schema name to create a spatial view

 From the Table Name list, select the name of the spatial table. The table must contain an 
SDO_GEOMETRY column. After selecting the table from the list, a check will be done to 
ensure that a primary index, referencing a NUMBER column, exists on the table. This 
column will automatically be mapped as the GID column to uniquely identify each spatial 
object. If this check fails, the following message is displayed: “This table does not contain 
an appropriate primary key constraint. A primary key constraint must exist on a numeric 
column to uniquely identify each individual spatial object”.
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Figure 40 Selecting a spatial table name from the list

 From the Geometry Column list, select the appropriate columns that you want to use. This 
list only becomes available when there is more than one geometry column in the table. If 
only one column is present in the table, this column will be selected automatically.

4 In the Spatial Characteristics group, do the following:

 In the View Name field, enter the name of the view that you are creating. The name will 
prefixed with SP_ and will have the same restrictions as are applied to a Munsys spatial table 
with regard to naming conventions such as length, etc.

 In the Spatial Object Description field, enter a unique description for the spatial layer. This 
description will be displayed when the spatial data is queried.

 From the Geometry Type list, select the geometry type of the objects that the table will be 
associated with. The options available in the list will depend on the geometry type that is 
currently stored in the table. The following options are available:

 Lines – in the case of lines or polylines this option will be unavailable and will be defaulted 
to lines.

 Polygons – in the case of polygons, two options will be available; Polygon and LW Poly-
gon. The LW Polygon option allows you to query polygon objects as objects that are 
derived from the LWPOLYLINE object, instead of objects that are derived from the 
MPOLYGON object. 

 Points – if the original table contains points, thee options will be available; Point, Symbol 
or Label. The geometry of the SDO_GEOMETRY column will be used to represent a 
point or a label (text). The Point and Symbol options do not differ much, but are named 
this way to cater for both terms, as not all users would want a symbol to represent the 
geometry, but rather a AutoCAD point. The Label option will use the geometry to repre-
sent the insertion point of the text.
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Figure 41 Specifying the spatial characteristics of the view

5 Click OK to create the spatial view as specified.

Munsys creates the view, inserts it into MUNSYS_SP_TABLES, creates the associated system 
query and grants SELECT privileges to the view.

Figure 42 Spatial View Added confirmation message

Note The process that creates the spatial view will use columns in the original table that conform to the default 
Munsys naming convention. All additional columns required that do not exist in the table will be added 
to the view. This will ensure that the structure of the view is based on the required structure as expected 
by Munsys. The structure of the view is determined by the type of geometry selected as explained above. 
The column name and data types of columns in the view are important, but the Oracle database 
administrator can edit the view through another interface to influence the values represented by the 
columns, as long as the column names and data type of the columns above the GEOMETRY column are 
not influenced. The default system query that is created can be modified using the query palette to 
overwrite many of the values in the view, for example Tag Value, Tag Justification, Tag Style, Tag 
Height, Symbol Name, Symbol Scale, etc.
Querying spatial data in Munsys 75 










Removing a spatial view

The Remove Spatial View function is used to remove previously added external spatial tables 
from the Munsys system tables. Entries referencing the view are removed from the 
MUNSYS_SP_TABLES and MUNSYS_QUERY system tables, and the view is dropped. 

Note The function only removes the view, and does not drop the original spatial table to which the view refers.

To remove a spatial view

1 On the command line, enter MUNREMOVESPVIEW.

The Remove Spatial View dialog box is displayed.

Figure 43 The Remove Spatial View dialog box

2 Select the spatial view that you want to remove, and then click the Remove button.

Entries referencing the view are removed from the MUNSYS_SP_TABLES and 
MUNSYS_QUERY system tables, and the view is dropped.
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About cadastral data
The term cadastral refers to a map or survey showing administrative boundaries and property 
“lines”. Cadastral data is defined as an official register of the ownership, extent and assessed 
value of land for a given area, and also as the geographic extent of the past, current, and future 
rights and interests in real property including the spatial information necessary to describe that 
geographic extent. In Munsys, cadastral data is used as the base data set.

Munsys uses the following cadastral base data:
 Communities – a community is a residential area containing one or more legal boundaries, 

and can be a township, suburb or municipality.

 Parcels – a distinct portion of land, which is captured from a registered plan by means of 
coordinates or angles of direction and distance. Parcels are important spatial data in the 
Munsys system, as many of the capture functions rely on the location of parcels.

 Blocks – a block boundary binds a group of parcels with the edges of the road reserve, and 
is used to represent the cadastral data on a higher scale when the detail of the parcels is not 
required.

 Easements – a registered area attached to a parcel for the benefit of the local authority. This 
area is used for the installation of services or right of way; therefore the landowner is not 
allowed any permanent construction.

 Buildings can be classified as different types according to the default values set up by the 
system administrator. New building types can be added to the list of available building 
types.

 Street names and addresses – legal street names are assigned to sections of the road reserve 
and display as text. The address information is assigned at a specific point within the parcel 
polygon. In some cases, parcels can have more than one point of entry, and are therefore 
assigned multiple address points.

 Cadastral notes – additional notes pertaining to cadastral objects.
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Querying cadastral data from the database from the Query menu
The following section explains how to query cadastral data from the database using the pre-
defined (default) queries that are available on the Query menu of each Munsys application. For 
more “refined” queries, you can use the functions on the Query Palette, with which you can 
create customized queries.

Querying suburbs

Communities (suburbs, townships or municipalities) are queried from the database according 
to the current GSC, or by a selected community name. Suburbs are displayed as polygons 
(MUNPOLY objects).

To query communities by name

1 Choose Query > [Suburbs] > By Name...

The Select [Suburb] dialog box is displayed, showing a list of all the available suburbs with their 
associated codes. The list of suburbs can be sorted ascending or descending, according to the 
municipality code or description.

2 From the list of suburbs, select the suburb that you want to query, and then click OK.

Figure 44 Querying a suburb by name

Tip If you want to query more than one suburb, press and hold down the SHIFT key (to select consecutive 
suburbs), or press and hold down the CTRL key, and then select each suburb that you want to query. You 
can also search for a specific suburb by its name by selecting the Description button, and then entering 
the first few letters of the name, or search for a name by its code by selecting the Code button, and then 
entering the applicable code.

The suburb boundary is 
queried onto its own layer
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Figure 45 Querying more than one community at a time

To query suburbs by GSC

 Choose Query > [Suburb] > By GSC.

The suburb boundaries are retrieved according to the GSC settings and the current GSC.

Figure 46 Querying suburbs by GSC

Window GSC with the mask 
set to Within, and shown as a 
solid outline.

The Fairview municipality 
boundary, queried according to 
the current GSC.
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Querying parcels

Parcels are queried from the database according to the current GSC, and are displayed as 
polygons (MUNPOLY objects). Parcels with a legal status of Current are queried onto the 
PARCEL_C layer, and parcels with a legal status of Proposed are queried onto the PARCEL_P 
layer. 

To query parcels

 Choose Query > Parcels.

The command line shows how many parcels were retrieved according to the current GSC. 

Figure 47 Parcels queried from the database according to the current GSC
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Querying block boundaries

Block boundaries are queried from the database according to the current GSC, and are 
displayed as polygons (MUNPOLY objects). Block boundaries are placed on the BLOCK layer.

 Choose Query > Block Boundaries.

The command line shows how many block boundaries were retrieved from the database 
according to the current GSC.

Figure 48 Querying block boundaries

Polygon GSC, with the mask 
set to Within, and shown as a 
solid outline.

Block boundaries are queried onto the 
BLOCK layer.
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Querying easements

Easements are queried from the database according to the current GSC, and are displayed as 
polygons (MUNPOLY objects) or lines (MUNLINE objects). Easements that are queried from 
the database are placed on layers according to their object type and easement type, for example 
a line-type easement with an easement type of General will be queried onto the 
EASELINE_GENERAL layer, while a easement polygon with an easement type of Reserve will 
be placed on the EASEPOLY_RESERVE layer. Easement text is queried onto either the 
EASEPOLYTXT or EASLINETXT layers, depending on the object type of the easement.

To query easements

 Choose Query > Easements.

The command line shows how many easement lines, polygons and text respectively were 
retrieved according to the current GSC.

Figure 49 Querying easements

Easement line text is queried onto 
the EASELINETXT layer.

An easement line, queried onto its 
appropriate layer
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Querying street names

Street names are queried from the database according to the current GSC, and are displayed as 
labels (MUNLABEL objects). Street names are placed on the STRTXT layer.

To query street names

 Choose Query > Street Names.

The command line shows how many street names were retrieved from the database 
according to the current GSC.

Figure 50 Querying street names

Tip If the insertion point of the text falls outside the current defined GSC, the text item will not be queried 
from the database
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Querying street addresses

Street addresses are queried from the database according to the current GSC, and are displayed 
as labels (MUNLABEL objects). Street addresses are placed on the STRADDR layer.

To query street addresses

 Choose Query > Street Addresses.

The command line shows how many street addresses were retrieved from the database 
according to the current GSC.

Figure 51 Querying street addresses

Tip If the insertion point of the text falls outside the current defined GSC, the text item will not be queried 
from the database

Street addresses are queried 
onto the STRADDR layer
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Querying buildings

Buildings are queried from the database according to the current GSC, and are displayed as 
polygons (MUNPOLY objects). Buildings are placed on the BUILDING layer.

To query buildings

 Choose Query > Buildings.

The command line shows how many buildings were retrieved from the database according 
to the current GSC.

Figure 52 Querying buildings

Buildings are queried onto the 
BUILDING layer
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Querying cadastral notes

Cadastral notes are queried from the database according to the current GSC, and are displayed 
as labels (MUNLABEL objects). Cadastral notes are queried onto the 
CMSNOTE_NOTE_TYPE_TEXT layer.

To query cadastral notes

 Choose Query > Cadastral Notes.

The command line shows how many cadastral notes were retrieved from the database 
according to the current GSC.

Figure 53 Querying cadastral notes

Cadastral notes are queried onto the 
CMSNOTE_NOTE_TYPE_TEXT layer
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Browsing information
The Browse function is used to browse the contents of one or more tables or views of a currently 
logged on schema. The user privileges and access rights assigned determine the list of tables, 
views and queries that are available for browsing.

The browse selection opens a re-sizable mode-less browsing window so that the user can view 
the queried objects in the drawing while browsing the attribute information in the browsing 
window. Multiple Browsing windows can be opened simultaneously to view attribute data for 
different spatial objects, for example Sewer Pipes and Sewer Nodes.

Using the Browse Info... menu option the user is presented with the Browse Selection dialog 
box with a Queries tab and Table/Views tab as the first step to identifying the source of the 
content to browse. The Queries tab displays all system and user defined queries available to the 
user according to their assigned roles and privileges. The Tables/Views tab allows the user to 
browse information directly from tables, views, lookup tables, attribute templates or queried 
objects in the drawing according to their assigned roles and privileges.

Browse Selection

When initiating the browse command from the Query > Browse Info... menu item or from 
typing the command MUNBROWSE in the command line, the user is presented with the 
Browse Selection dialog box which has the following two tabs:

 Queries tab - displays a list of all user and default system queries available to the user 
dependent on their roles assigned.

 Tables/Views tab - displays a list of table items that are available to the user dependent on their 
roles assigned.

On the Queries tab the user is presented with a list of Query Categories which, when expanded, 
display a list of User Queries and default System Queries. The availability of query categories and 
their associated queries is dependent on the roles assigned to the user. A user with the role 
MUNSYS_ALL_QUERY will have access to view all the spatial tables in the database.

Figure 54 Browse Selection - Queries tab
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Figure 55 Browse Selection - Tables/View tab

Tip The Browse function can also be initiated by typing the command MUNBROWSE on the command line.

Browsing Info using predefined Queries

The user can select a user defined or system defined query to browse attribute information from 
the database. The query properties and filter conditions saved with the query determine what 
information is displayed in the Browse window.

To browse info using a predefined query

1 Do one of the following:

 Choose Query> Browse Info...

 or type MUNBROWSE on the command line
The Browse Selection dialog box is displayed

2 Expand the query category required, highlight the query to browse from the list of queries on the 
Queries tab and then click OK.
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Figure 56 Selecting the table to browse from a list of predefined queries

Once the query has been selected, the result is populated to the Browsing Info window and is 
displayed in a table or grid format, including a row for every record and a column to specify the 
type of attribute information available. The Browsing window is menu driven and is sensitive 
to content selection. The result set can be refined by applying filters. The active result set is used 
at all times as input to the functions available on the menus. 

The following menu items are available on the Browsing Info window:

 File – generates reports from the active result set, which allows the termination of the 
browse using the Close function.

 Edit – the user is allowed to copy selected rows to the clipboard, find a specific value or go 
to a specific record number as well as edit attributes or linked attributes for selected records.

 View – determines the result set by applying various filters and applying formatting of 
values.

 Records – this menu is only applicable when the primary table is a spatial table. The user 
can determine the spatial objects to query and once queried, can zoom to the spatial objects 
in the drawing and/or highlight equivalent objects.

Important  This function will not allow a user to browse information from views if the join on the two 
tables does not consist of a primary key on any of the two tables. The user will be presented with Oracle 
error: ORA-01455: cannot select ROWID from, or sample, a join view without a key-preserved 
table. To prevent this error you need to add a primary key constraint or unique index to one of the tables 
used to define the view.
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Figure 57 The Browsing: Info window

Tip All column headers are sortable (toggle between ascending or descending) when selected in the Browsing 
result set.
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The Browsing Info Window

Open queries for Browsing
The user can browse the contents of one or more tables or views without exiting the Browsing 
Info window by selecting the File > Open... menu item where the user will be presented with a 
dialog box of predefined user and system queries to select from. Selecting a query will populate 
the result set in the Browsing Info window and any attribute conditions assigned to the selected 
query will be applied to the result set.

Generating reports
This function allows the user to save the current result set to a Comma Separated Value file 
(CSV). The user is presented with the standard Save As dialog box, and navigates to the required 
path for saving the result set. The output format is a standard text file where the comma 
character (,) usually separates each field of text. Due to the simplicity of a CSV file, it is 
compatible with various other applications.

1 On the Browsing Info window, choose File > Report to file...

The Save As dialog box is displayed.

2 Navigate to the appropriate folder, and then type the file name in the File Name text box.

3 Click Save.

4 The information bar on the dialog box displays the number of records that were saved.

Note The report is set to save as a CSV file by default, but the user has the option to save the report as a TXT 
or HTML file by selecting the Save as type: drop down list.

Editing Attributes
The Edit > Edit Attributes... menu item prompts the user to select one or more spatial objects 
from the drawing to edit. Once the selection has been made the Edit Attributes dialog box is 
displayed allowing the user to edit the spatial object attributes that belong to the same object 
type. (See Chapter 4-32)

The current application determines what object types may be selected; for example, if you are 
working in Munsys Sewer, only sewer objects may be selected. The command line prompts the 
user to select the type of object expected, for example: Select water objects:

If you select more than one object type, for example sewer pipes and sewer nodes, you will be 
required to choose a single object type to edit.

Editing Linked Table Attributes
The Edit > Edit Linked Table Attributes... menu item prompts the user to select one or more 
spatial objects from the drawing to edit. Once the selection has been made the Linked Table 
Attributes dialog box is displayed allowing the user to edit the attributes for the linked table. 
(See Chapter 4-35)

If no linked table has been defined a No Linked Table warning message is displayed 
No attribute templates exist with appropriate linked tables.
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Finding results
The Edit > Find... menu item searches through the entire result set, finds the matching record(s) 
and allows you to select a record from the Find Info results and locate and highlight the record 
in the Browsing Info results set. 

On the Find dialog box, you must enter the value(s) to search for, as well as indicate the column 
in which to search. The columns available from the lookup list includes columns from linked 
tables, as well as columns that were not identified as available columns when browsing the data. 
The search operation can be refined by applying more search parameters including an exact or 
partial match. 

Tip The search is affected by the Display Formatted Values option (available on the View menu). If this 
option is active the search will ignore the raw values and search for formatted values. The value in the 
search is case sensitive at all times.

Figure 58 Finding records by applying search criteria

Finding a row number
The Edit > Goto Row Number menu item allows the user to search for a specific row number 
within the result set. If the required row number is found, it is displayed and selected. Should 
the required row number not be found, a message to this effect will be displayed.

Copying results

The Edit > Copy menu item allows users to copy a selection from the result set to the clipboard 
for pasting into other applications. Column headings are copied with the selected records. 
Columns and records are comma delimited text and may be pasted to any application that 
accepts text.
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Filtering by attributes
With the Filtering by attributes function, you can filter the current result set by applying an 
attribute filter that is constructed by attribute conditions. Once the attribute conditions are 
applied on the current result set, it is refreshed with the new values. The Attribute Condition 
dialog box is used to construct the filter that will be used to apply to the initial result set. For 
users who are not familiar with SQL statements, Munsys provides drop-down lists in the order 
required to easily construct the applicable filter. The Attribute Condition is used to construct 
complex filters that contain more than one attribute condition.

1 Choose View > Filter by Attributes...

The Attribute Conditions dialog box is displayed showing the existing conditions applied to the 
query.

Figure 59 The Attribute Condition dialog box

2 To define a condition statement, the user can either edit or remove the existing attribute conditions 
or add additional attribute conditions. To add attribute conditions select do the following:

 Select the Add button to display the Add Condition dialog box.

Figure 60 The Add Condition dialog box
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 From the Column drop-down list, select the appropriate column to determine the criteria.

 From the Operator drop-down list, select the operator that best suits the condition that you want 
to check. Operators include <=, =, >=, etc. Use these operators to produce the desired spatial 
result.

 In the Value option, enter the criteria that will be tested against the value of the column and that 
qualifies the condition operator.

Tip You can select the Values... button to get a list of unique values from the database for the column selected 
for the criteria. The list is limited to display the first 50 records, but by checking the Show All check box 
all the values in the database for the selected column are displayed.

 Click the OK button to add the condition to the Condition dialog box.

3 To define your own criteria start typing the SQL statement in the SQL Equivalent box.

 Enter a SQL statement, and then click OK.
The condition syntax will be checked and errors reported. A valid condition statement will 
automatically be added to the Condition dialog box.

4 Click OK to apply the attribute filter.

The Browsing Info dialog box is refreshed with the new result set.

Filtering by GSC
The View > Filter by GSC menu item filters spatial data according to the current GSC. The 
current GSC is zoomed to the extents of the drawing area while the Browse Info dialog box is 
still active. This spatial filter is also applied on the current result set that is displayed in the 
Browse Info dialog box.

This function does not replace any previous defined attribute or spatial filters that are active but 
complement these.

Filtering by spatial objects
This function applies a spatial filter to the current result set by prompting the user to select 
Munsys objects in the current drawing. When activating the option, the user will be requested 
to select the appropriate spatial objects that are used as the filter. Once the user has selected these 
objects, the Browse Info dialog box is updated accordingly.

This filter criteria will replace all previously defined spatial filters, but complements attribute 
and GSC filters.

1 Choose View > Filter by Spatial Objects.

2 Select the appropriate spatial objects in the drawing, and then press ENTER.

The Browse Info dialog box is updated accordingly.

3 To reset the Browse Info dialog box, use the Clear All Filters option on the View menu.

Note The filter by spatial objects selection is restricted to 1000 records. If more than 1000 records are selected, 
the user will be presented with a message and will be required to reselect the objects from the drawing. 
Maximum number of selected records exceeded. Please limit the selection to 1000 spatial objects.
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Filter selected objects only

The View > Filter Selected Object Only function allows the user to select records in the Browsing 
window grid and use that record selection to update the results in the Browsing window. The user 
can select the records individually or hold down the Shift key to do a group selection, or hold down 
the Ctrl key to do multiple record selection.
The user highlights the records to filter on in the grid and then selects the menu item to update 
the resultant selection set.

Clearing all filters
The View > Clear Filter menu item is used to clear all of the previously defined filters, and is 
therefore only available when at least one filter has been specified. Once the function is 
activated, the result set is refreshed with no filters applied.

Displaying formatted values
The View > Display Formatted Values menu option is used to display more descriptive 
information in the result set, for example, rather display the land use description instead of a 
code. Column headings are also affected by this setting, headings are displayed with appropriate 
descriptions. If descriptions are not available the column name is prefixed with the table name. 

The formatted values affect the data display in the result set, generating of reports, copying of 
selected records and the find function.

Viewing SQL statements

The View > SQL Windows opens a SQL window at the top of the Browsing window and 
displays the SQL syntax for the current selection set. This SQL statement is updated when ever 
filter conditions are applied. The user can copy the SQL statement from the SQL window for 
use within SQLPlus or for documentation purposes.

Figure 61 View > SQL Window displays the SQL syntax for the current selection set.
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Setting an object query
This function is used to select a spatial query that will be used when querying spatial objects 
from the database. The available spatial queries are determined by the spatial table, identified 
on the Browse Content dialog box. The selected spatial query will be used to query the spatial 
objects associated with the result set.

1 Choose Records > Set Object Query...

The Available Queries dialog box is displayed and the queries relating to the selected spatial 
table are expanded by default.

Figure 62 The Available Queries dialog box

2 Select the appropriate system query from the list, and then click OK.

The required system query is set.

Querying objects
The Query Objects function allows the user to select records in the Browsing list and then query 
them into the drawing. The associated Munsys objects are created in the current drawing. The 
system query that was identified during the Set Object Query... function is used to determine 
the formatting parameters when querying spatial objects from the database.

1 On the Browsing Info dialog box, select the appropriate record/s from the result set.

2 Choose Records > Query Objects.

The associated spatial record/s is queried into the current drawing onto the appropriate spatial layer.

3 To view the queried spatial objects, see Zooming to objects.
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Zooming to objects
This function is used to locate queried spatial objects. Once the user has selected the 
appropriate record in the result set, the Zoom to objects function automatically zooms to the 
associate spatial object in the drawing. The aggregated extents of the object encountered is used 
to change the zoom state of the drawing.

1 On the Browsing Info dialog box, select the appropriate record from the result set.

2 Choose Records > Zoom to Objects.

The associated spatial object is zoomed to the extent of the screen.

Highlighting objects
This function is used to select a records in the result set, and then highlights the associated 
spatial objects in the drawing. The zoom state of the drawing remains unchanged during this 
operation.

1 On the Browsing Info dialog box, select the appropriate record/s from the result set.

2 Choose Records > Highlight Objects.

The associated spatial objects are highlighted in the drawing.

3 To zoom to the highlighted record, refer to Zooming to objects.

Highlighting records
This function is used to select spatial objects in the drawing and then highlights the associated 
records in the result set. The user is required to select at least one spatial object in the drawing. 
The user will only be able to select the spatial objects in the drawing associated with the primary 
table identified.

1 On the Browsing Info dialog box, select the appropriate record/s from the result set.

2 Choose Records > Highlight Records.

The associated records in the result set are highlighted.

3 Use the Records > Clear Highlighted Records menu item to clear the highlighted records.
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Figure 63 Combination of highlighting records and objects when browsing

Browsing Tables and Views

If the Browse Window function is initiated from either the Query > Browse Info menu item of 
by typing the command MUNBROWSE at the command line, Browse Info dialog box with 
the Tables/Views tab is displayed. The user must select one of the following items to browse:

 All Tables - lists all tables in the database.

 Attribute Templates - lists all attribute templates in the database.

 Lookup Tables - lists all lookup tables in the database.

 Queried Objects - lists the tables for objects queried into the drawing.

 Spatial Tables - lists all spatial tables in the database.

 Views - lists all spatial views in the database.
Once the user selects one of the items to browse, the Browse Selection dialog box is displayed 
and a list of all available tables are populated to the content pane.
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Figure 64 Tables/Views: All Tables

To select a table to browse

1 On the Select item to browse list of items, select one of the items from the list.

2 Once selected, the content pane on the right will be populated with a list of available tables and or 
views according to the roles assigned to the user.

3 Select a table from the content pane and then click OK.

The Browsing window will open and the resultant list will display all records in the table. The user 
can then apply filter conditions to refine the number of records in the result set. See The Browsing 
Info Window.
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Showing information about spatial objects

Introducing the Munsys Info Palette

The Munsys Info Palette replaces the Show Info functionality (which showed spatial data and 
attributes connected to a selected spatial object) that was available in previous versions of 
Munsys.

Figure 65 The Munsys Info Palette

The Info Palette is activated in the AutoCAD environment with the MUNINFOPALETTE 
command, or by selecting the Info Palette > On menu item from the Query menu. The palette 
is dockable and remains open until the user closes it.

The Info Palette toolbar contains the following buttons:

 Copy – allows the selection of entire rows, entire columns, or separate cells to copy.

 Edit Spatial Attributes – displays the Edit Attributes dialog box, which is used to edit the 
attributes of the selected object.

 Info Palette Preferences – displays the Info Preferences dialog box, which is used to set the 
default preferences for Modified Attributes, Data Formatting and Link Template Results.
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If the Info Palette is open and a Munsys Object is selected, the palette is updated with the details 
of the selected object. If a non-Munsys object is selected, or more than one object (these may 
or may not include Munsys Objects), the content of the palette is cleared, as the Info palette is 
only populated upon selection of a single Munsys Object.

Important  The way that objects are selected on the Info Palette is dependent on the 
MUNINFOSELECT command. This command is used to toggle the behavior of the auto-select option 
in the Info Palette. If the Info Palette auto-select is set to On (the default setting for each session), the Info 
Palette is populated with the properties of any one object that is selected in the drawing while another 
command is not active. If the auto-select is set to Off, the Info Palette is only populated when an object is 
selected using the Select Object button, as seen below:

Figure 66 Show Info: Select Object
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The Info Palette is divided into the following three tabs:

 Attributes – displays the attributes for the selected object. A Display Template is selected 
from the list of available templates.

Figure 67 Info Palette: Attributes tab
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 Linked Attributes – displays  information as defined in a selected Link Template.

Figure 68 Info Palette: Linked Attributes tab
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 Object Info – displays detailed information regarding the selected object, separated into 
predefined groups.

Figure 69 Info Palette: Linked Attributes tab

When you right-click on a value on the Attributes or Linked Attributes tabs, a context-sensitive 
menu becomes available, which is used to copy data and specify formatting options.

Figure 70 Info Palette: Context-sensitive menu
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Specifying Info Palette preferences
The Info Preferences dialog box is used to specify default preferences for certain items on the 
Info Palette.

To specify Info Palette Preferences, do the following:

1 Click the Info Palette Preferences button on the Info Palette toolbar.

The Info Preferences dialog box is displayed, showing the Modified Attributes tab, which is 
used to specify the preferred view the user has on modified values.

Figure 71 Info Preferences: Modified Attributes

2 Select one of the following options:

 Display modified attributes in a separate column – modified attributes are displayed in a 
separate column. 

 Integrate modified attributes – modified attributes will not be displayed separately
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3 Click the Data Formatting tab, which is used to specify the preferred data format options.

Figure 72 Info Preferences: Data Formatting

4 Select one of the following options:

 Display formatted values

 Display unformatted values

5 Select the Link Template Results tab, which is used to set the preferred size for the Link Template 
results.

Figure 73 Info Preferences: Link Template Results

6 Specify the following:
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 Table Size – specify the preferred size for the Link Template results. A value can be entered 
manually, or by using the arrows.

 Table View – select the Table View or Column View option to specify the way in which the 
table data is displayed.

7 Click OK to apply the preferences to the Info Palette.
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Setting a coordinate system
With Munsys, you can set the drawing coordinate system to be different from the database 
coordinate system. By setting the drawing coordinate system, you can query objects from the 
database coordinate system into a drawing coordinate system. The data transformation will be 
done during the query. You have to make certain that the database and drawing coordinate 
system are compatible for the specific area that you are working in. The administrator has the 
option to set the scale and rotation of text and symbols to remain as it is in the database. The 
settings can be verified on the Capture Settings dialog box under the General group (the 
Capture Settings dialog box is accessed from the first menu item of each application’s Capture 
menu, for example Capture > Sewer Settings...). New and changed objects can be posted to the 
database while the drawing coordinate system is set. The data will be transformed to the 
database coordinate system as part of the posting process.

To set a coordinate system

1 Choose Extras > Set Coordinate System...

2 The Set Coordinate System dialog box is displayed.

Figure 74 The Set Coordinate System dialog box

3 From the Coordinate System Selection group, select the category in which the required coordinate 
system is grouped.

4 From the Coordinate Systems in Category list, select the appropriate coordinate system, and then 
click OK.

Once the coordinate system is set, data is queried from the database and is displayed in the 
coordinate system set above.
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Munsys reports
A Munsys report consists of information that is generated from existing attribute data. To 
generate a Munsys report, you have to specify for which spatial objects the report will be created, 
and which attribute data assigned to these spatial objects should be used.

The result of the report is saved in a text file format – CSV (comma delimited). Commas 
separate columns of data, and each row of data ends in a carriage return. The text file can be 
opened in a word processing program or spreadsheet.

A Munsys report contains the following type of information:

 The first line indicates which spatial table is used to create the report.

 The second line contains the date and time that the report was created.

 The third line contains the field names that the user selected when creating the report.

 The body of the report contains information only for the selected spatial objects.

To create a report

1 Choose Extras > Report...

2 Select the spatial objects to create the report from, and then press ENTER.

The Table Names dialog box is displayed.

Figure 75 The Table Names dialog box

The Table Names dialog box contains a list of all the tables of the selected spatial objects.

3 From the list of tables, select a table, and then click OK.

The Column Names dialog box is displayed.
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Figure 76 The Column Names dialog box

4 From the list, select the columns to include in the report, and then click OK.

The Save report as dialog box is displayed.

Figure 77 The Save report as dialog box

5 Enter a file name for the report, and then click Save.

The report opens in Microsoft Notepad® as a text file.
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